CNNVD 关于Oracle WebLogic Server远程代码执行漏洞的通报

2019-06-17 99868人围观 ,发现 2 个不明物体 漏洞

*本文中涉及到的相关漏洞已报送厂商并得到修复,本文仅限技术研究与讨论,严禁用于非法用途,否则产生的一切后果自行承担。

近日,国家信息安全漏洞库(CNNVD)收到关于Oracle WebLogic Server远程代码执行漏洞(CNNVD -201906-596)情况的报送。攻击者可利用该漏洞在未授权的情况下发送攻击数据,实现任意代码执行。该漏洞是由于Oracle WebLogic Server一个历史漏洞(CNNVD-201904-961)修补不完善导致。

CNNVD已于2019年4月23日发布了该漏洞预警,尽管4月26日Oracle发布了补丁,但近日发现该漏洞仍可被新的攻击方式利用。Oracle WebLogic Server 10.3.6.0、12.1.3.0等版本均受漏洞影响。目前, Oracle官方暂未发布该漏洞补丁,但可以通过临时修补措施缓解漏洞带来的危害,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。

一、漏洞介绍

Oracle WebLogic Server 是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间件,它提供了一个现代轻型开发平台,支持应用从开发到生产的整个生命周期管理,并简化了应用的部署和管理。

2019 年4月26日,Oracle官方发布了OracleWebLogic Server远程代码执行漏洞(CNNVD-201904-961)的修复补丁,但是在同年6月16日,国家信息安全漏洞库(CNNVD)收到了该漏洞补丁被绕过并利用的情况报送,攻击者可以在未经授权的情况下,远程发送HTTP请求,最终实现远程代码的执行。

二、危害影响

攻击者可利用漏洞在未授权的情况下远程发送攻击数据,最终实现远程代码执行。Oracle WebLogic Server 10.3.6.0、12.1.3.0等版本均受漏洞影响。

三、修复建议

目前, Oracle官方暂未发布该漏洞补丁,但可以通过临时修补措施缓解漏洞带来的危害,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。

1、通过访问策略控制禁止 /_async/* 及 /wls-wsat/* 路径的URL访问,此操作可能会造成业务系统无法正常使用,可通过白名单机制允许授权用户访问.

2 、在明确不使用wls-wsat.war和bea_wls9_async_response.war的情况下, 建议直接删除该组件并重启WebLogic服务器。

3 、建议使用WebLogicServer构建网站的信息系统运营者进行自查,发现存在漏洞后,按照临时解决方案及时进行修复。

本通报由CNNVD技术支撑单位——知道创宇404实验室提供支持。

CNNVD 将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系,联系方式:cnnvd@itsec.gov.cn。

*本文作者:CNNVD,转载请注明来自FreeBuf.COM

相关推荐
发表评论

已有 2 条评论

取消
Loading...

特别推荐

推荐关注

活动预告

填写个人信息

姓名
电话
邮箱
公司
行业
职位
css.php