Metasploit官方攻防模拟实训工具:Metasploit Vulnerable Services Emulator发布

2017-03-07 510500人围观 ,发现 7 个不明物体 工具

如何用最好地保护一个系统免受黑客攻击?当然是站在黑客的视角来看待系统的安全问题。昨日Metasploit就以此为出发点,发布了一个漏洞模拟工具——Metasploit Vulnerable Services Emulator。作为一款开源工具,安全人员可以通过它提供的漏洞操作平台来测试渗透测试目标。

想到之前的Metasploitable2Metasploitable3也有同样的功能,为什么还要特地出一个Metasploit Vulnerable Services Emulator?

开发者Jin Qian在他的博客中这样写道:

使用没有脆弱性测试服务的Metasploit去对抗黑客攻击是有难度的,我们开发的这个模拟器就是为了填补这个空缺。这款工具的框架使得操作者能够更轻松地对渗透测试目标进行漏洞仿真测试。

很多人可能会想,为什么我们不给每个测试、训练模块配置脆弱性测试服务。原因很简单:这很耗费时间,且配置脆弱性测试服务很复杂。首先,你需要有漏洞软件,需要下载吧,但是有时候软件太老了没有地方下载。有些较老的软件还可能因为安全问题被厂商移除了。针对一个软件配置脆弱性测试服务需要耗费几个小时,时间长短取决于这个软件。即便有Metasploitable虚拟机使你在第一次建立漏洞实验室便捷很多,但是依然不简单。

设计这个模拟器有两个目的:

●测试Metasploit模块

●帮助用户学习Metasploit

核心特性:

为了更容易地添加测试服务,Metasploit Vulnerable Services Emulator 完全独立于机器语言,由JSON格式编写,任何人都可以快速地添加、删除、编辑测试服务。

*新的工具还有这样一个小功能:创建SSL套接字会非常容易,所有TCP套接字都可以自动升级到SSL。

现在,Metasploit Vulnerable Services Emulator已经拥有100多个脆弱性测试服务,包括被黑的身份凭证,从受害者那里获得shell等等。 通过模块练习后,用户可以了解有关安全漏洞及其测试方法的详细信息,进而鼓励用户继续学习和使用Metasploit的强大功能。

Screen+Shot+2017-02-26+at+6.00.57+PM.png

开发者Qian:

我们知道开发人员对编程语言有不同的偏好,因此我们不使用特定语言来实现脆弱性测试服务,而是采用JSON实现交互。

JSON不是一种编程语言,但它有足够的逻辑用于服务仿真。

以下是对脆弱性测试服务在JSON中的描述。

"exploits/windows/iis/ms01_023_printer": {
  "desc": "set payload windows/shell_reverse_tcp",
  "seq": [
    ["regex", "GET http:\/\/.*\/NULL.printer?"],
    ["HTTP/1.1 200 OK\r\nContent-Length: 0\r\n\r\n", ["action", ["connect", ":4444"]]]  
 ]
},

目前Metasploit Vulnerable Services Emulator已经有Linux (Ubuntu)、Windows、Mac版本,只需要先安装Perl就可安装。

下载地址:GitHub

*参考来源:securityaffairsgithubrapid7,FB小编bimeover编译,转载请注明来自Freebuf.COM

更多精彩
相关推荐

这些评论亮了

  • fake 回复
    Metasploit反应太慢了,struts的poc还没出来,差评
    )9( 亮了
发表评论

已有 7 条评论

取消
Loading...

特别推荐

推荐关注

活动预告

填写个人信息

姓名
电话
邮箱
公司
行业
职位
css.php