无线网络渗透工具:Infernal-Twin

2015-11-10 535110人围观 ,发现 8 个不明物体 工具无线安全

文中提及的部分技术、工具可能带有一定攻击性,仅供安全学习和教学用途,禁止非法使用!

Infernal-Twin是一个自动化的渗透测试工具,开发目的是通过自动化的Evil Twin攻击来评估无线的安全性。

“开发该工具是为了帮助审计员和渗透测试者快速的进行无线安全评估,减少复杂的攻击向量。”

注意,正如通常所发生的那样,渗透测试工具经常被黑客滥用于违法活动,因此我决定将其呈现出来,以散播攻击者兵工厂中存在潜在武器的意识。

攻击场景

开始解释攻击场景吧。在Evil Twin攻击中,攻击者首先建立一个虚假的WiFi接入点,声称会提供无限网络服务,但是却会偷偷的窃取用户的流量。

伪造的接入点会提供给用户一个虚假的网络登录页面,以窃取他们的WiFi凭证和其他敏感数据。这种攻击场景还可被用于进行中间人攻击或者向目标网络中的电脑里植入恶意程序。

首先,你需要安装所有必要的组件,包括Apache模块、mysql数据库、Scapy 数据包操纵工具和wxtools调试框架。

其次,还必须安装Aircrack-ng工具,并从资源库中获得Infernal-Twin。Aircrack-ng是一个网络软件组,包括探测器、数据包嗅探器、WEP和WPA/WPA2-PSK解密工具、802.11无线LAN分析工具。

按如下步骤安装组件:

$ sudo apt-get install apache2
$ sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql
 
$ sudo apt-get install python-scapy
$ sudo apt-get install python-wxtools
$ sudo apt-get install python-mysqldb
 
$ sudo apt-get install aircrack-ng
 
$ git clone https://github.com/entropy1337/infernal-twin.git
$ cd infernal-twin

bug修复

启动Infernal-Twin工具需要有超级管理员权限。一些用户在连接到数据库时发现了一些问题,用户@lightos 给出了如下的解决方法。

在数据库上创建一个新的用户,新用户账号配合一下步骤即可启动Infernal-Twin工具:

1. 从Infernal无线文件夹中删除dbconnect .conf文件

2. 在mysql控制台上运行如下命令

mysql> use mysql;
 mysql> CREATE USER ‘root2’@’localhost’ IDENTIFIED BY ‘enter the new password here’;
 mysql> GRANT ALL PRIVILEGES ON \*.\* TO ‘root2’@’localhost’ WITH GRANT OPTION;

3. 再次运行Infernal-Twin工具

Infernal-Twin工具实现了数个功能,无线社工、WPA2/ WEP无线入侵等;

GUI无线安全评估SUIT
实施
WPA2入侵
WEP入侵
WPA2企业入侵
无线社工
SSL地带
报告生成
PDF报告
HTML报告
笔记功能
数据保存在数据库中
网络映射
MiTM
探测请求

Infernal-Twin作者Khalilov M, aka 3ntr0py (entropy1337)称下次他发布的工具将会解析t-shark日志文件,搜集受害者凭证和其他数据。

下面视频展示的是对公共网络的攻击,脚本可以进入并能修改登录页面,改变必要变量的内容。

下面这个视频是对Infernal-Twin工具的具体解释。

推荐

如果你对无线渗透感兴趣的话,推荐你看下WiFiPhisher。它是一个WiFi社工工具,可以窃取到用户WiFi网络的凭证。Github上已经可以下载该工具!

下载地址:https://github.com/sophron/wifiphisher/releases/tag/v1.1

*参考来源:securityaffairs,编译/简单,转载请注明来自FreeBuf黑客与极客(FreeBuf.COM) 

更多精彩
发表评论

已有 8 条评论

取消
Loading...

特别推荐

推荐关注

填写个人信息

姓名
电话
邮箱
公司
行业
职位
css.php