Percona Server 再次澄清 MySQL 的安全漏洞问题

2012-06-20 73956人围观 ,发现 1 个不明物体 资讯

Percona ServerPercona XtraDB Cluster 和很多其他的 MySQL 变种一样,多多少少都会受到 MySQL/MariaDB 的 sql/password.c 中存在的登录密码漏洞的影响,之前的消息表明只有通过源码编译方式安装才会存在漏洞,但经过更多的实践表明,某些预编译的版本也存在漏洞,Percona 对此问题进行了调查,确定了以下几个问题:

在某些硬件/虚拟化平台上的 64bit Ubuntu Oneiric (11.10) 的 Percona Server 预编译版本存在此漏洞,目前已确认的在 Amazon EC2 存在此问题
Ubuntu 11.10 之前后者之后的版本不受影响
11.10 不是一个 LTS 版本,大部分针对服务器的版本,如 10.04 LTS 和 12.04 LTS 是不受影响的
最新的 Percona Server 预编译版本 5.1.63 和 5.5.24 不受影响。
这个登录密码漏洞是一个非常复杂的问题,依赖于特定的软硬件平台,我们为之前发表的声明表示道歉,因为那个声明可能引起你的误会。

与以往一样,我们建议你使用最新的 Percona Server 版本。

编者:看来此漏洞远非如此简单。

发表评论

已有 1 条评论

取消
Loading...
css.php