freeBuf
WordPress爆高危漏洞插件,可被用来创建非法管理员帐户
2023-07-03 11:58:02
所属地 上海

1688351776_64a23420f178527ba21a6.png!small?1688351776696

WordPress网站的终极会员插件中有多达20万个未修补的关键安全漏洞,如今面临着很高的攻击风险。
该漏洞被追踪为CVE-2023-3460 (CVSS得分:9.8),影响所有版本的Ultimate Member插件,包括2023年6月29日发布的最新版本(2.6.6)。
Ultimate Member是一个比较受欢迎的插件,它有助于在WordPress网站上创建用户配置文件和社区,并可提供帐户管理功能。
WordPress安全公司WPScan在警报中提到,这是一个非常严重的问题,因为未经身份验证的攻击者可能会利用这个漏洞创建具有管理权限的新用户帐户,从而实现夺取网站的完全控制权。
但该漏洞源于不适当的阻止列表逻辑,所以无法将新用户的wp_capabilities用户元值更改为管理员的用户元值,从而获得对站点的完全访问权。
Wordfence研究员Chloe Chamberland称,虽然该插件有一个预先定义的禁用键列表。但还有一些更简单的方法可以绕过过滤器,例如在插件的易受攻击版本中利用各种大小写,斜杠和提供的元键值中的字符编码。
有报道称,受影响的网站上出现了一些非法管理员账户,因此该插件在2.6.4、2.6.5和2.6.6版本发布了部分修复程序,还有一个新的版本更新预计将在未来几天发布。
WPScan指出,这些补丁是不完整的,已经发现了许多绕过它们的方法,这意味着该漏洞仍然可以被积极利用,比如,该漏洞被用于以apadmins、se_野蛮、segs_野蛮、wpadmins、wpengine_backup和wpenginer等名称注册新帐户,通过网站的管理面板上传恶意插件和主题。
此外WPScan还建议广大用户,直到该安全漏洞被完全修复前,都建议Ultimate Member的用户禁用该插件,最好审计网站上的所有管理员级用户,以确定是否添加了未经授权的帐户。

终极会员2.6.7版发布

7月1日,Ultimate Member的作者发布了该插件的2.6.7版本,以解决被积极利用的特权升级漏洞。作为一项额外的安全措施,他们还计划在插件中发布一个新功能,使网站管理员能够重置所有用户的密码。
此外, 网站维护人员还表示:2.6.7引入了我们在发送表单时存储的元键白名单,并且分离了表单设置数据和提交数据,可在两个不同的变量中操作它们。

本文为 独立观点,未经允许不得转载,授权请联系FreeBuf客服小蜜蜂,微信:freebee2022
被以下专辑收录,发现更多精彩内容
+ 收入我的专辑
+ 加入我的收藏
文章目录