freeBuf
主站

分类

漏洞 工具 极客 Web安全 系统安全 网络安全 无线安全 设备/客户端安全 数据安全 安全管理 企业安全 工控安全

特色

头条 人物志 活动 视频 观点 招聘 报告 资讯 区块链安全 标准与合规 容器安全 公开课

官方公众号企业安全新浪微博

FreeBuf.COM网络安全行业门户,每日发布专业的安全资讯、技术剖析。

FreeBuf+小程序

FreeBuf+小程序

内存安全周报第44期 |西门子解决了常见CAD库中发现的代码执行漏洞
2021-06-15 11:52:40

安芯网盾内存安全周报专栏,希望帮助企业更好的理解内存安全相关问题。让用户更好的认识、发现问题,防止外部入侵等威胁、有效的对系统进行安全设计,以实时防御并终止无文件攻击、0day /Nday攻击、缓冲区溢出攻击、基于内存的攻击等。

一、西门子解决了常见CAD库中发现的代码执行漏洞(5月27日)

Siemens发布报告称,其Solid Edge产品受到5个漏洞的影响,包括4个高度严重的内存损坏问题(允许远程代码执行),以及一个中度严重的XXE bug(可能导致信息泄露)。通过诱骗目标用户处理恶意的CATPart、3DXML、STP、PRT或JT文件,可以利用这些漏洞。

详细信息

Solid Edge是一个产品开发解决方案,包括3D设计、仿真、制造和设计管理工具。

通过对漏洞的分析发现,这些漏洞是通过使用Luxion公司制作的3D渲染和动画解决方案KeyShot引入的。进一步分析表明,这些缺陷实际上是由Datakit CrossCad/Ware引入的,这是KeyShot用来导入各种CAD(计算机辅助设计)格式的库。

迄今为止,似乎只有西门子、KeyShot和CISA发布了这些漏洞的警告,但CrossCad/Ware也被许多其他产品使用,它们可能都存在漏洞。总部位于法国、专门从事CAD数据交换解决方案的Datakit在其网站上说,它作为OEM与100多家供应商合作,其中包括许多北美和亚太地区的供应商。

Luxion已发布KeyShot 10.2,其中包括Datakit库的修补版本,西门子已建议Solid Edge客户按照Luxion的安全公告中的说明更新KeyShot 。

参考链接:https://www.securityweek.com/siemens-addresses-code-execution-vulnerabilities-found-popular-cad-library?&web_view=true

二、野外利用Checkbox Survey中的代码执行缺陷(5月26日)

Cannegie Mellon University的CERT协调中心(CERT / CC)警告说,这种Checkbox Survey漏洞可能允许远程攻击者执行未经身份验证的任意代码。

详细信息

Checkbox Survey是一种用ASP.NET编写的灵活的在线调查工具,可帮助组织创建专业问卷调查,可以从台式计算机或移动设备轻松访问这些调查。

在Checkbox Survey中发现的缺陷(跟踪为CVE-2021-27852)与视图状态数据的不安全反序列化有关,这是ASP.NET页面框架用于保存页面和控件值的一种方法。

在7.0版之前,Checkbox Survey通过_VSTATE参数使用了自己的视图状态功能,该参数使用LosFormatter反序列化。通过向使用Checkbox Survey 6.x或更早版本的服务器发出特制请求,未经身份验证的远程攻击者能够利用Web服务器的特权执行任意代码。

据报道该漏洞已在攻击中被利用,但未提供有关这些攻击的信息。

参考链接:https://www.securityweek.com/code-execution-flaw-checkbox-survey-exploited-wild?&web_view=true

三、VMware vCenter Server中发现严重的RCE漏洞(5月25日)

近日,VMware vCenter Server中发现了一个严重的关键安全漏洞,攻击者可以利用该漏洞在服务器上执行任意代码。

详细信息

VMware vCenter Server是一种服务器管理实用程序,用于从单一集中位置控制虚拟机,ESXi主机和其他从属组件。

其漏洞CVE-2021-21985(CVSS评分9.8)源于Virtual SAN(vSAN)运行状况检查插件中缺少输入验证,该插件在vCenter Server中默认启用。

VMware表示,具有网络443端口访问权限的恶意行为者可能会利用此问题在托管vCenter Server的基础操作系统上以不受限制的特权执行命令。

该缺陷影响vCenter Server 6.5、6.7和7.0版本以及Cloud Foundation 3.x和4.x版本。该修补程序版本还纠正了vSphere Client中的身份验证问题,该问题会影响Virtual SAN运行状况检查,站点恢复,vSphere Lifecycle Manager和VMware Cloud Director可用性插件(CVE-2021-21986,CVSS得分:6.5),从而允许攻击者无需任何身份验证即可执行插件允许的操作。

参考链接:https://thehackernews.com/2021/05/critical-rce-vulnerability-found-in.html?&web_view=true

本文作者:, 转载请注明来自FreeBuf.COM

# web安全 # 内网渗透 # 漏洞分析 # 网络安全技术
被以下专辑收录,发现更多精彩内容
+ 收入我的专辑
评论 按热度排序

登录/注册后在FreeBuf发布内容哦

相关推荐
\
  • 0 文章数
  • 0 评论数
  • 0 关注者
登录 / 注册后在FreeBuf发布内容哦
收入专辑