青莲晚报(第六十二期)| 物联网安全多知道

当今社会物联网设备已经逐步渗透到人们生产生活的方方面面,为人们及时了解自己周围环境以及辅助日常工作带来便利。但随着互联紧密度的增高,物联网设备的安全性问题也逐渐影响到人们的正常生活,甚至生命安全,物联网设备安全不容小觑。 以下为近日的物联网安全新闻内容。

微信公众号-青莲晚报封面图-58.jpg

四款 D-Link 路由器发现无法修复的漏洞 唯一选择是弃之不用

DIR-652,DIR-655,DIR-866L和DHP-1565这四款D-Link路由器中发现了严重的安全漏洞。非认证的命令注入漏洞——CVE-2019-16920,成功利用该漏洞可以导致远程代码执行。因为该漏洞可以在不经过认证的情况下远程触发,因此研究人员将该漏洞评为中危。如果你不幸的拥有这四款路由器中任意一款,那么为了你的安全唯一的选择就是弃之不用,因为这个漏洞永远无法修复,来自Fortinet的安全专家上周透露,上述四款路由器中存在一个“未经身份认证的命令注入漏洞”,黑客可以利用该漏洞执行任意远程代码。换言之,遍布全球的黑客可以非常容易的劫持这些路由器,然后监视你的互联网流量,或者引导你到恶意网站上。不幸的是,其中一种型号DIR-866L于2014年推出,已经在2018年停产。另一种型号DIR-655,于2006年推出,也在去年停产了。而DIR-655, DIR-866L和DHP-1565这三款路由器依然能够亚马逊美国官方网站进行购买,而且DIR-655还是亚马逊的推荐路由器型号。如果你去年购买了路由器,那么你肯定希望能够正常使用12个月以上,尤其是亚马逊官方推荐的路由器型号。类似于Netgear等一些路由器厂商,在停产之后依然会提供安全更新。不过D-Link是在设备停产之后就不再提供安全更新,因此在选购之前还需要考虑它的上市时间,以及它的支持周期。

详文阅读:

http://hackernews.cc/archives/27646

 

SIM卡又出现新漏洞 威胁用户信息安全

此前,SIM卡被曝出存在一个严重的漏洞,攻击者可以在用户不知情的情况下发送短信攻击目标手机。现在安全研究人员又公布了一个新漏洞,威胁到用户的个人信息安全。

据介绍,新漏洞名为WIBattack,该漏洞危及到一些SIM卡上的WIB(无线互联网浏览器)应用程序,以控制关键的电话功能。攻击短信会在没有启用关键安全功能的SIM卡上运行指令。一旦成功,入侵者可以发送信息,启动呼叫,并将受害的网络浏览器指向特定的站点,显示文本和发送位置信息。

该漏洞目前还在研究阶段。外媒称,拥有WIB功能的SIM卡的“数亿”手机可能面临风险。但根据一份SRLabs报告,表明潜在受害者的真实人数可能要低得多。

详文阅读:

http://toutiao.secjia.com/article/page?topid=112040

 

存在至少 4 年的 Linux 漏洞被发现:可通过 WiFi 攻击目标计算机

一位安全研究人员表示,由于Linux中存在的严重安全漏洞能导致使用WiFi信号的附近设备崩溃,或者完全被黑客掌控。名叫 Nico Waisman 的安全研究人员发推文称,该漏洞位于RTLWIFI驱动程序中,而该驱动程序用于在Linux设备上支持Realtek WiFi芯片。

据悉当具有Realtek Wi-Fi芯片的计算机在恶意设备的无线电范围内时,该漏洞将会在Linux内核中触发缓冲区溢出问题。该漏洞不仅可以引起操作系统崩溃,而且还允许黑客完全掌控计算机。该缺陷可追溯到2013年发布的Linux内核的3.10.1版本。

Github的首席安全工程师Nico Waisman表示:“这个漏洞非常严重,只要您使用Realtek(RTLWIFI)驱动程序,此漏洞就可以通过Linux内核上的Wi-Fi远程触发溢出。”漏洞跟踪为CVE-2019-17666。 Linux开发人员在星期三提出了一个修复程序,很可能在未来几天或几周内将其合并到OS内核中。只有在此之后,该修补程序才能进入各种Linux发行版。

详文阅读:

http://hackernews.cc/archives/27795

 

Linux 曝出 Sudo 提权漏洞 受限用户亦可运行 root 命令

作为 Linux 中最常使用的重要实用程序之一,Sudo 几乎安装在每一款 UNIX 和Linux 发行版上,以便用户调用和实施核心命令。然而近期曝出的一个提权漏洞,却直指 sudo 的一个安全策略隐患 —— 即便配置中明确不允许 root 用户访问,该漏洞仍可允许恶意用户或程序,在目标 Linux 系统上以 root 用户身份执行任意命令。

据悉,Sudo 特指“超级用户”。作为一个系统命令,其允许用户以特殊权限来运行程序或命令,而无需切换使用环境(通常以 root 用户身份运行命令)。

默认情况下,在大多数 Linux 发行版中(如屏幕快照所示),/ etc / sudoers 的 RunAs 规范文件中的 ALL 关键字,允许 admin 或sudo 分组中的所有用户,以系统上任何有效用户的身份运行任何命令。

然而由于特权分离是 Linux 中最基本的安全范例之一,因此管理员可以配置 sudoers 文件,来定义哪些用户可以运行哪些命令。

这样一来,基板限制了用户以 root 身份运行特定或任何命令,该漏洞也可允许用户绕过此安全策略,并完全控制系统。

Sudo 开发者称: “只要 Runas 规范明确禁止root 访问、首先列出 ALL 关键字,具有足够 sudo 权限的用户就可以使用它来以 root 身份运行命令。”

据悉,该漏洞由苹果信息安全部门的 Joe Vennix 追踪发现(CVE-2019-14287)。且想要利用这个 bug,只需 Sudo User ID -1 或 4294967295 。

这是因为将用户 ID 转换为用户名的函数,会将 -1(或无效等效的 4294967295)误认为 0,而这正好是 root 用户User ID 。

此外,由于通过 -u 选项指定的 User ID 在密码数据库中不存在,因此不会运行任何 PAM 会话模块。

详文阅读:

http://hackernews.cc/archives/27757

 

百万Echo和Kindle设备受到Wifi漏洞影响

近年来,越来越多的物联网设备实现智能化。虽然很多厂商在产品中都内置了一些安全措施,但ESET研究人员发现即使是Amazon Echo也受到2017年的Key Reinstallation Attack (KRACK)漏洞的影响。研究人员还发现Amazon Kindle电子阅读器也存在类似的漏洞。

KRACK 攻击

2017年,研究人员Mathy Vanhoef和Frank Piessens发现目前主流WiFi网络中的安全协议WPA2标准中存在安全漏洞。KRACK攻击主要攻击4次握手,这是一种确认客户端和AP能够处理正确的凭证,和协商流量加密所用的密钥的一种机制。

Vanhoef等人研究发现攻击者可以通过伪造和重放加密握手消息来诱使受害者设备重新初始化当前会话中使用的密钥。通过利用该漏洞,攻击者可以逐渐重构加密的 XOR 流,然后嗅探受害者网络的流量。

Alexa?

从发现KRACK漏洞至今已经过去2年了,但是许多WiFi设备仍然受到该攻击的影响。ESET研究人员发现包含Amazon设备在内的许多设备就受到该漏洞的影响。Amazon在美国就销售了上千万台Echos设备,Kindle的销量也超过千万,因此带来了很大的潜在安全威胁。

研究人员测试了Amazon Echo 1代和Kindle 8代设备,测试主要关于设备对不同KRACK攻击的弹性。结果表明Echo 1代和Kindle 8代设备易受到2类KRACK漏洞的攻击。利用Vanhoef的脚步,研究人员浮现了4次握手加密密钥对(PTK-TK)的重安装(CVE-2017-13077)和组密钥(GTK)的重安装(CVE-2017-13078)。

这些漏洞非常严重,因此攻击者利用这些漏洞可以:

· 重放包来执行DoS攻击,破坏网络通信或重放攻击。

· 解密受害者传输的任意数据或信息。

· 根据网络配置来伪造数据包、使设备丢包、甚至注入新的包。

· 拦截口令或session cookie这样的敏感信息。

研究人员还发现Amazon家用设备易受到另外一个网络漏洞的攻击——广播重放攻击。该攻击是指一个有效的广播传播被欺诈性地重复,然后被目标设备接受。攻击者可以利用该攻击来发起DoS攻击或为未来的加密分析或暴力破解攻击来收集包。

详文阅读:

https://www.4hou.com/info/news/21029.html

取消
Loading...

相关推荐

填写个人信息

姓名
电话
邮箱
公司
行业
职位
css.php