Kali Linux渗透测试系统使用小记

2013-04-09 428558人围观 ,发现 24 个不明物体 系统安全

感谢SuperMan投递

版本汉化:

因为是基于Debian的,那么得用Debian的汉化过程,

命令:

dpkg-reconfigure locales

选择字符编码:en_US.UTF-8、zh_CN.GBK、zh_CN.UTF-8

选择字符:zh_CN.UTF-8

设置完后reboot

 

中文输入法:

命令:

apt-get install ibus ibus-pinyin

reboot后右键点击右上角的输入法图标->首选项->输入法+中文->高级(勾上所有程序共享使用同一个输入法)

 

VPN:

安装network-manager-pptp-gnome之后网络管理器的VPN菜单的添加按钮才能用

 

运行 Metasploit Framework:

依照Kali Linux网络服务策略,Kali没有自动启动的网络服务,包括数据库服务在内,所以为了让Metasploit以支持数据库的方式运行有些必要的步骤,

启动KaliPostgreSQL服务

Metasploit使用PostgreSQL作为数据库,所以必须先运行它

service postgresql start

可以用ss -ant的输出来检验PostgreSQL是否在运行,然后确认5432端口处于listening状态

State Recv-Q Send-Q Local Address:Port Peer Address:Port

LISTEN 0 128 :::22 :::*

LISTEN 0 128 *:22 *:*

LISTEN 0 128 127.0.0.1:5432 *:*

LISTEN 0 128 ::1:5432 :::*

 

启动KaliMetasploit服务:

随着PostgreSQL的启动和运行,接着我们要运行Metasploit服务,

第一次运行服务会创建一个msf3数据库用户和一个叫msf3的数据库,还会运行Metasploit RPC和它需要的WEB 服务端

service metasploit start

Kali运行msfconsole

现在PostgreSQL 和 Metasploit服务都运行了,可以运行 msfconsole,然后用 db_status 命令检验数据库的连通性

msfconsole
msf > db_status
[*] postgresql connected to msf3
msf >

 

配置Metasploit随系统启动运行 :

如果你想PostgreSQLMetasploit在开机时运行,你可以使用update-rc.d启用服务

update-rc.d postgresql enable
update-rc.d metasploit enable

这些评论亮了

  • 周鸿伟 回复
    没有360操作系统强!
    )50( 亮了
  • 0x80 回复
    关于汉化:这东西安装的时候不就可以选择中文吗,装完直接就是中文的
    )15( 亮了
发表评论

已有 24 条评论

取消
Loading...
css.php